Introduction to Queries

A **QUERY** in Raiser’s Edge is a grouping of similar records in the database. The query module enables us to group, sort and output different types of records. To create a new query, go to the query module and select “New Query”. You will be prompted to select a **Query type** and **Query format** in a window that looks like below:

When selecting a query type, ask yourself “What type of records do I want in the output”? Do I want to see constituent records, gift records, action records, fund records or other types of records? The **Constituent** type query is used most often and is used to group individual and organization records. The two query formats are dynamic and static. A **dynamic** query refreshes itself every time you run it, so if more or fewer records meet your criteria when you run the query in the future, then the new results will be reflected in your query. A **static** query is a snapshot of the records in a database. That means the results in your query will never change or be updated unless you manually refresh the query. Click OK to open your new query.
Criteria Tab

The grouping filters called “criteria” are the most important part of a query. This is where you define which group(s) of records you want to pull from the database. Each filter relates to a field, sub-record or property of a record. The key to finding filters is to know which field(s) on the record relates to the information you want to group on. So for instance, if you want to find all Alumni in the state of FL, you have to know where the Alumnus code is stored and where State is stored. Once you know how and where the data is stored, finding it in the query is the easy part.

Criteria Operators

Criteria operators and values are used by the query to determine which records you want to pull for a specific filter. When you click on a filter from the criteria tab, you’ll see the below pop-up with the operator and value selections. See below for examples of all the operators.

Edit Field Criteria

<table>
<thead>
<tr>
<th>Operator</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals</td>
<td>Preferred State equals Virginia</td>
</tr>
<tr>
<td>Does not equal</td>
<td>Preferred State does not equal South Carolina</td>
</tr>
<tr>
<td>Greater than</td>
<td>Birth Date greater than 1/1/1984</td>
</tr>
<tr>
<td>Less than</td>
<td>Birth Date less than 1/1/1932</td>
</tr>
<tr>
<td>Greater than or equal to</td>
<td>Gift Amount greater than or equal to $500</td>
</tr>
<tr>
<td>Less than or equal to</td>
<td>Gift Amount less than or equal to $50</td>
</tr>
<tr>
<td>One of</td>
<td>Education Major one of: Agriculture, Packaging Science, Dairy Science</td>
</tr>
<tr>
<td>Not one of</td>
<td>Solicit Code not one of: No Solicitation, No marketing mail or calls</td>
</tr>
<tr>
<td>Between</td>
<td>Education Class of between 1992 and 2005</td>
</tr>
<tr>
<td>Not Between</td>
<td>Education Class of not between 2006 and 2008</td>
</tr>
<tr>
<td>Blank</td>
<td>Nickname blank</td>
</tr>
<tr>
<td>Not Blank</td>
<td>Preferred Email Number Not Blank</td>
</tr>
<tr>
<td>Begins with/Does not begin with</td>
<td>Last Name begins with J</td>
</tr>
<tr>
<td>Contains/Does Not Contain</td>
<td>Gift Fund Description contains Agriculture</td>
</tr>
<tr>
<td>Ask</td>
<td>This operator will ask for an operator and value when the query is ran</td>
</tr>
</tbody>
</table>
Criteria Nodes/Fields
There are nodes that represent different groups of criteria that you can use to group on. You see these in “Available fields” when you first open a query. Below are some important nodes (and specific criteria within those nodes) with descriptions that you can use to query constituent records.

Inactive, Deceased and No Valid Address - Check boxes at the top of the query. Uncheck these boxes to remove each of those groups from the query.

Constituent Information - Biographical fields, record properties, specific records, (Most fields on the BIO 1 tab except for Spouse, Address and Solicit Codes)

Spouse - Information about a constituent’s spouse relationship record and constituent record (if they have one)

Constituency - Constituent code (example values: Alumnus, Corporate Foundation, Former Student, Faculty, Friend)

Solicit Codes - Codes on the bottom left of the BIO 1 tab that indicate a person does/does not want to be contacted for certain reasons. Examples: No Contact Wanted, Clemson Word Only, No Solicitation, Botanical Gardens Only, No Marketing Mail or Calls

Addresses - Preferred Address fields, (address lines, city, state, zip, county)

Phones - Includes phones, emails, faxes and other contact numbers. There’s a specific phone node (to query on specific phone types like “Phone” and “E-mail”)

Primary Alumni Information - fields related to a constituent’s Primary Education Relationship. (Date Graduated, Degree, Major, Minor, School. The school (CBBS for example) that the constituent attended is stored in the Campus field. This particular filter always applies to the first degree a student has earned from Clemson.
**Primary Business Information** - fields related to the constituent’s main business relationship (Company Name, position, company address, contact information, etc.)

**Actions** - Fields on a constituent’s actions record (type, date, solicitor, status, for example)

**Relationships**
- Assigned Solicitor- (fields specific to the assigned solicitor for the constituent: Solicitor name, Solicitor Type)
- Education- (fields specific to the education relationship: school name, date graduated, degree, campus, major, minor)
- Individual- (Individual relationship fields: name, address, contact info, relation type (parent, child, employee etc))
- Organization- (Organization Relationship fields: relation type, position, matching gift information)

**Gifts** - Fields on a constituent’s gift records (date, gift amount, type, receipted, acknowledged, etc). This node also has sub nodes for Campaigns, Funds and Appeals. Example: Gifts>Funds>Fund College = College of Business and Behavioral Science

**Prospect** - Information from the prospect tab on a constituent’s record. This includes Ratings, Proposals, etc...

**Attributes** - Information about constituents’ attributes including (category, description, date). *When querying on attributes, there’s a sub node of Specific Attribute. This is what’s typically used to query on attributes. From specific attributes, choose the attribute you want to filter on and select “Description” and then choose a table value, enter a text value or choose the operator of blank/not blank (if you need to see constituents who do/don’t have the attribute)

**AND/OR Query Operators & Parentheses**
At the bottom right of the query, you will see buttons for “AND”, “OR”, and left/right parentheses. These options are used for grouping criteria. Here are descriptions for each of the operators. When adding criteria, the system adds “AND” operators between criteria by default.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND</td>
<td>The default combining operator in Query. Records must meet both criteria to be selected.</td>
<td>Last Name equals Smith AND State equals SC&lt;br&gt; selects all constituents whose last name is Smith and whose state is SC. John Smith is only selected if he also has a state of SC.</td>
</tr>
<tr>
<td>OR</td>
<td>Records can meet either criterion to be selected.</td>
<td>Last Name equals Smith OR State equals SC&lt;br&gt; selects all constituents whose last name is Smith and selects all constituents with a state of SC. For example, John Smith is selected because his last name is Smith -- he does not need a state of SC. Mary Jones is selected if she has a state of SC.</td>
</tr>
<tr>
<td>Parentheses ( )</td>
<td>Use parentheses to group query criteria when necessary.</td>
<td>For more information, refer to How to use parentheses in query (BB24257).</td>
</tr>
</tbody>
</table>
Parentheses

Parentheses are used to group criteria when both AND and OR operators are used.

Example: Let’s say that you wanted to find all constituents who are residents of South Carolina and are either alumni or have given a single gift of $500 or more.

Here is the query written without parentheses:

Preferred State equal South Carolina
AND Constituent Code equals Alumni
OR Gift Amount is greater than or equal to $500

The query reads the OR operator first and will pull all residents of South Carolina who are alums and all constituents who have given a $500+ gift regardless of what state they live in. An OR operator without parentheses doesn’t associate with criteria above it.

Here is the query written with parentheses:

Preferred State equal South Carolina
AND (Constituent Code equal Alumni
OR Gift Amount is greater than or equal to $500)

This query pulls all residents of South Carolina who either (are alumni OR have given a gift of $500+)

Output, Sort and Results Tabs

Once you have your criteria selected, you can go to the Output tab to select output fields for the constituents you grouped together on the criteria tab. The tab looks nearly identical to the criteria tab. To select an output field, double click it. You will then see that it moves over to the “output” section on the right. So for example, you may have grouped all Alumni in FL on the criteria tab, but for those people, you want to see name, address, age, class year and major. You would select those fields from the output tab.

You can sort your output by any field(s) by selecting it on the SORT tab. The field list again is identical to the criteria and output tabs. If you plan on exporting the data, you’ll want to sort in the query the same way you want it to sort in the exported file.
The **Results** tab is where you preview the results of your query (by clicking “Run Now” on the bottom right). It will display all the output that you selected from the output tab. **Note- You can open any record in your results by double clicking on the row that corresponds to that record (this works for most query types).**

*Duplicates in Query Results*- When viewing the results in a query, you could see duplicate records if you have one-to-many fields in the output or in your criteria. So for example, if you output constituent code and a person has 4 constituent codes, four rows will appear for them in the results. If you see duplicates in your query, you can remove them in your export file (excel/access for example). You can also run the query through the **Export Module** which will automatically de-duplicate your query.

**Other Query and Export Options**

**Favorites**- For query fields/criteria that you use frequently, you can add them to your favorites by **Right Clicking on the field and selecting “Add to Favorites”**. The Favorites node appears at the very top of the criteria list and will include all the fields that you have added as favorites.

**Creating a Copy of a Query**- If you see a query that has all or nearly all the criteria that you need in it, instead of creating a new query from scratch or changing that query (**Never change a query that you didn’t create**), go to **File>Save As** and rename the copy of the query for yourself (much like you would an MS office file).

**Soft Credit and Matching Options in Query**- To change the way a query handles soft credit donors/recipients, go to **“Tools>Query Options>Gift Processing”** and select who should get credit for soft credits and matching gifts.

**Exporting from a query**- To export your query results to a file, click on the export icon (looks like a CD) from the query tool bar. Then specify a file type (excel, CSV, access, etc...) and file name (click on the ellipses to specify the name and where you want to save the file). Remember that the export tool from a query will output your results exact as they appear (including duplicates) if there are any. You’ll have to use either the export module or the “remove duplicates” tool in excel to remove the dupes.

For questions about queries or to schedule a query training session, contact Josh Isengard at jisenga@clemson.edu